Let's talk about the Drift HD

Status
Not open for further replies.

kryten

Wannabie Member
Jul 23, 2011
365
73
28
I ride a
GSXR-600 and WR250R
Ok so after several people suggested the Drift HD I decided to get one and try it out. At first I loved it. The freedom of being able to open and close my helmet to get air and not having a camera shoved up my nose was wonderful. The camera seemed to produce a sharp image but it was a little dark. The video it produced was tolerable.

Then I did a firmware update. I'm not sure if there was a new default setting in the update that killed it but now my videos are very blurry. They almost look as bad as first generation GoPro videos. Has anyone else had that experience since updating the firmware? I haven't had this many camera issues since my early days of vlogging and trying in vain to get a good camera angle with my V570.
 

Chessecake94

Wannabie Member
Jul 23, 2011
918
0
16
I ride a
Honda Hornet - With Beast Of A Micron Exhaust
I've still not updated mine since I got it, I've never had a problem with the Drift, bit they do seem to be very hit and miss as to whether they work for people.
 

ariderslife

Wannabie Member
Jul 26, 2011
879
79
28
33
Melbourne - Australia
www.youtube.com
I ride a
Currently: 2004 CB 919 - Previous rides - Honda Hornet 600 aka CB599 - Previous: 1999 Honda VTR 250: Previous Honda f4i - Previous: CBR 929 Previous: DRZ400sm: Previous 2006 gsxr 600: Previous 1989 Honda Spada VT250
kryten said:
Ok so after several people suggested the Drift HD I decided to get one and try it out. At first I loved it. The freedom of being able to open and close my helmet to get air and not having a camera shoved up my nose was wonderful. The camera seemed to produce a sharp image but it was a little dark. The video it produced was tolerable.

Then I did a firmware update. I'm not sure if there was a new default setting in the update that killed it but now my videos are very blurry. They almost look as bad as first generation GoPro videos. Has anyone else had that experience since updating the firmware? I haven't had this many camera issues since my early days of vlogging and trying in vain to get a good camera angle with my V570.
sounds liek the censor came loose and its outa focus.

if so,

claimed under warranty.
 

DanTehMan010

Wannabie Member
Dec 28, 2011
22
0
0
34
Sheffield
I ride a
2012 Suzuki DL650 V Strom AL2
Same happened to me with my first HD170 I got at the NEC, after its first update it was fracked! told actioncameras.co.uk and boom! sent back and got a full brand new unit + mounts and cables before Crimbo :p
 
Status
Not open for further replies.

Top Posters Past 30 days

Winners Video