Is the Home button dropdown menu as intended?

Dec 20, 2015
540
349
63
26
I ride a
Yamaha Fazer
#1
1529686536216.png

clicking it takes me to the SEO site, I think such a link would be better suited in the bottom bar or something.

Also, the sites Favicon is broken, shows just a paper-icon unless there are new notifications.
 
Likes: Lurch
Dec 20, 2015
540
349
63
26
I ride a
Yamaha Fazer
#4
This little icon in the browser tabs
1529691376166.png

Should be a little Motovlog logo instead, which is the case when you have notifications.
 
Likes: HippoDrone

Lurch

Administrator
May 5, 2014
5,533
2,059
113
Yorkshire
I ride a
2016 Street Triple R and a 1999 Honda NT650V Deauville
#7
Can you screenshot what’s taking you to the SEO site? I can’t find how to make it do it?
 
Likes: F4celess
Dec 20, 2015
540
349
63
26
I ride a
Yamaha Fazer
#8
Can you screenshot what’s taking you to the SEO site? I can’t find how to make it do it?
I literally just click the little arrow betweeen the "Home" and "Forums" button as shown in the screenshot in the first post. Then I click that link and it takes me to the site.
I even did a hard refresh of the site and it's still there so it can't be a lingering artifact from earlier days.
 

Lurch

Administrator
May 5, 2014
5,533
2,059
113
Yorkshire
I ride a
2016 Street Triple R and a 1999 Honda NT650V Deauville
#10
It’s an option in a drop down on mobile, must react differently on desktop. Not something I’ve access to sadly.
 
Dec 20, 2015
540
349
63
26
I ride a
Yamaha Fazer
#11
It’s an option in a drop down on mobile, must react differently on desktop. Not something I’ve access to sadly.
Odd, both the Mobile and Desktop version displays the dropdown and the link just fine for me.
it's not like the menu pops up by itself or anything. Just questioning the intention of leaving the link there. Not complaining or anything.
 

Top Posters Past 30 days

Latest posts

Winners Video

Want your video here?
Supported by Suffolk SEO who helps maintain this site.