Drift HD170 Stealth suction cup problem

Status
Not open for further replies.

MrSquirrels

Wannabie Member
Jul 28, 2011
4
0
0
I ride a
2007 GSXR 600
Does anyone else that has this have an issue with it shaking violently? My neighborhood has some really smooth streets and it looks like an earthquake when I did a test recording. Anyone know of any solutions? I recently mounted it to the handlebar mount on my mirror and it's nice and smooth. But it's kind of limited in angles..
 

launch

Wannabie Member
Jul 25, 2011
24
0
0
Gnarth America
www.launchhelmetcams.ca
I ride a
Bunch of different two wheeled badboys.
Haven't heard much about excessive vibration. Perhaps it is that a) the mounting surface is vibrating a lot (windshield?) or that b) one of the joints in the mounting arm isn't able to tighten enough to the point of being locked in or c) the 1/4'' thread maybe isn't absolutely secure.

Those are the only 3 points on the assembly that I can think of which would allow for lots of vibration, right? if it is thread, maybe try a little rubber washer to tighten up the interface and dampen some vibration? If it is one of the joints in the mounting arm not locking up well enough, that could be warranty.
 

Chessecake94

Wannabie Member
Jul 23, 2011
918
0
16
I ride a
Honda Hornet - With Beast Of A Micron Exhaust
CurlyBlakey said:
Chessecake94 said:
CurlyBlakey said:
sticky tape

my answer to everything :)
gotta be duct tape
Aye but duct tape might be too hench for a mount, standard sellotape is far more tactile
good point, got to be extra strong though.
who needs an expert like lauch when you've got us
 

dafobra

Wannabie Member
Jul 23, 2011
13
0
0
www.youtube.com
I ride a
Honda CBR600F4i
hmmm,, no issues here..

I have mounted it to the windscreen, gas tank, and the lower fairings... where are you mounting yours?
 

MrSquirrels

Wannabie Member
Jul 28, 2011
4
0
0
I ride a
2007 GSXR 600
Hey guys, thanks for the responses. I had been considering tape... but never tried it out. All the joints are tight and secure. I used the suction cup on and in my car and it works without any problems. But on my windshield, over part of my headlight, and on the tank of my bike it's just terrible vibration.

Here's a video of what's happening. I kind of got rid of the audio because it was so bad, and the videos a bit on the long side, but it shows all three mounting areas.

[youtube]http://www.youtube.com/watch?v=-zilpH89u60[/youtube]
 

bakker46

Wannabie Member
Jul 23, 2011
51
2
6
42
Veenendaal
fzr600rw.blogspot.com
I ride a
Kawasaki zr7-s suzuki ux150 Triumph 3TA
I got the same problem with one of my suction cup mounts :D

[youtube]http://www.youtube.com/watch?v=99medqAvxcQ[/youtube]

Not as bad as your camera but it's shaking quite bad , i found that the problem is in the mount itself.
Got a second mount that is made of steel and is much more stable.



Left mount , more stable only four small suction cubs
Right mount , less stable but big and good suction cub
 

ariderslife

Wannabie Member
Jul 26, 2011
879
79
28
33
Melbourne - Australia
www.youtube.com
I ride a
Currently: 2004 CB 919 - Previous rides - Honda Hornet 600 aka CB599 - Previous: 1999 Honda VTR 250: Previous Honda f4i - Previous: CBR 929 Previous: DRZ400sm: Previous 2006 gsxr 600: Previous 1989 Honda Spada VT250
Cable ties fix everything
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
Pewit35 Camera Setups 9

Top Posters Past 30 days

Winners Video

Latest posts