DavVinci Resolve 15 in action

tarmacjapa

Tarmac Japan
Mar 9, 2019
52
45
18
39
I ride a
MT-07 Cafe Racer
Maybe I'm being dumb, but I heard the basic version was free, but can't for the life of me find a download link on their website. Can you point me in the right direction?
 

tarmacjapa

Tarmac Japan
Mar 9, 2019
52
45
18
39
I ride a
MT-07 Cafe Racer
Wow, I must have a low attention span. I didn't watch their intro vid/banner so didn't see the link. Downloaded and playing with it now. I'm sure I'll have more questions as I get into it. Maybe I can stop using After Effects now. Thanks
 

Foreigner0

Wannabie Member
Jun 3, 2016
94
91
18
51
I ride a
BMW F800GT
My PC isn't good enough. Won't work.... That's a damn shame
What do you mean by not working? If it's the timeline playback that's choppy, that's more of a feature than a bug.

There's a feature that creates a low res version of the footage for editing. Take a look at BlackMagic's Youtube channel and watch the tutorials on there. There's also a channel, Jay Are TV that is great for Davinci tutorials.

Granted, a more powerful machine will be better. Some even recomend external GPUs to liven things up a bit.

My 2015 MacBook Pro handles it well enough.
 
  • Like
Reactions: HippoDrone

tarmacjapa

Tarmac Japan
Mar 9, 2019
52
45
18
39
I ride a
MT-07 Cafe Racer
What do you mean by not working? If it's the timeline playback that's choppy, that's more of a feature than a bug.

There's a feature that creates a low res version of the footage for editing. Take a look at BlackMagic's Youtube channel and watch the tutorials on there. There's also a channel, Jay Are TV that is great for Davinci tutorials.

Granted, a more powerful machine will be better. Some even recomend external GPUs to liven things up a bit.

My 2015 MacBook Pro handles it well enough.
After install the software ran a system check and said my pc was ok, but when I open it there's some errors and I can't get into the software only the system setup menu. Something about open CL cuda or something...
 

Foreigner0

Wannabie Member
Jun 3, 2016
94
91
18
51
I ride a
BMW F800GT
After install the software ran a system check and said my pc was ok, but when I open it there's some errors and I can't get into the software only the system setup menu. Something about open CL cuda or something...
Windows machine right? Haven't used one in years :( sounds like a video card driver issue.

Maybe a driver/system update?
 

tarmacjapa

Tarmac Japan
Mar 9, 2019
52
45
18
39
I ride a
MT-07 Cafe Racer
Windows machine right? Haven't used one in years :( sounds like a video card driver issue.

Maybe a driver/system update?
I'll be getting a new pc when the summer bonus comes in, so for now I'll stick to after effects.
 

tarmacjapa

Tarmac Japan
Mar 9, 2019
52
45
18
39
I ride a
MT-07 Cafe Racer
I got it working after all. I'm so used to After Effects that it's pretty confusing to use, but I'll keep practicing. Color correction is very easy, that's for sure
 
Thread starter Similar threads Forum Replies Date
Foreigner0 Editing Talk 0

Similar threads


Top Posters Past 30 days

Winners Video

Want your video here?
Supported by Suffolk SEO who helps maintain this site.

Latest posts